HomePage Forums Naomi Support Naobian Can't Install Naobian on Pi 4

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #626

    Hi,

    I’m quite new to this, I followed the recommended steps to install Naobian through flashing of the image. The flashing was done successfully but my pi can’t be booted up at all. I had used balenaEtcher to perform the flash.

    Please help. Thank you

    #627

    The Naobian image should work fine with the Raspberry Pi 4. Have you been able to boot up Raspbian?

    You can also just install Raspbian 10 Buster (or really any Raspberry Pi Linux OS, but Raspbian is easier) and install Naomi on top of it.

    I have a Raspberry Pi 4B 4GiB machine here. I will try downloading Naobian-1.0 and installing it later tonight. Do you have the Pi connected to a TV, or are you running it headless?

    Thanks!

    #634

    Hi,

    Yeap I have a separate sd card which i used for raspbian buster and everything works fine. I have the pi connected to tv also.

    I have also tried to install naomi manually but there’s a yaml error. I will install it again later and post the full details of it.

    #635

    I have downloaded and burned Naobian-1.0.img to an SD card and tried starting my RPi4B with it which failed. Then I moved it to my RPi3B+ which booted correctly and I was able to access via SSH. There must be an incompatibility between Naobian and the RPi4B. I have been running Naomi on Raspbian Buster on the RPi4B for a while now, so I know the manual install works.

    I think Naobian is based on Raspbian Stretch, and according to this chart: https://en.wikipedia.org/wiki/Raspbian#Version_history Stretch is not compatible with the RPi4, which is probably the issue.

    Naomi is very much a work in progress at the moment. The whole system is set up to use plugins in order to encourage experimentation, so starting by getting the source directly from github git clone -b naomi-dev https://github.com/NaomiProject/Naomi.git --origin upstream is generally going to be a good idea.

    I’m not sure when the image will be updated to Buster.

    #636

    I’ll try to get a couple of buster images up later this weekend which should resolve the RPi4 issue.

    #637

    Hi,

    Oh I see but thanks for rectifying it. Also, I did a manual installation instead and got it to work on the pi 4, not too sure why the first time it didn’t worked. So I guess everything is good

    #638

    So you tried a manual installation first, then switched to Naobian, then re-did the manual installation and finally got it to work? When you did get it to work, which version did you use? (what was the git command line you used?)

    I’m curious because things have changed a lot in the last year.

    #639

    Yeap, that’s exactly what I did and I used the stable version (ver 2.2) for the manual installation.

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.